
Instructions for Use of Maple in Mathematics 251

Fall 2006

This document These instructions are made available in two formats with the same contents.
A printed version is distributed at the meeting in the IML during a recitation period early in the term, and a
PDF version is available from a semester web page linked to the main course page:

http://www.math.rutgers.edu/courses/251/

Printing When you print your worksheet in a Rutgers student lab, you need to use your
RUconnection card to identify yourself at the computer next to the printer before the printer will ac-
cept your job. You will also be able to modify the instructions to the printer (including canceling jobs that
you no longer want to print).

Why use Maple The purpose of the Maple assignments is partly to learn about Maple, a
powerful and very useful program for symbolic, numerical, and graphical computations, and partly to help
you understand the material in the course. Rutgers has a license that allows Maple to be available on many
systems, including eden, the PC labs, and departmental networks.

Aside from the required use of Maple in lab projects, there are other ways that this program may prove
valuable. It is an important part of this course because it can graph curves and surfaces in three dimensions,
solve complicated systems of equations, and perform all of the differentiation and integration operations met
in this course. The Student package allows you to examine the steps of many of these operations (through
Calculus I in Maple9, but a Multivariate Calculus package was added to Maple9.5). This package may be
useful in checking your homework and preparing for exams.

The current version of Maple is Maple10, which was released in the summer of 2005. This version
introduced a Document Mode that is supposed to be easier for beginners to use. This mode emphasizes
the appearance of the completed document, but it allows the underlying Maple instructions to be hidden.
Since you will be graded on the Maple instructions you use and your interpretation of the results of those
instructions, this format is less useful in course projects. Similarly, your worksheet should not use “Math
mode”. In “Text Mode”, the [> prompt identifies the expressions to be evaluated. Different types of
expressions are on separate lines. The T or [> tools in the Maple window should be used to insert text or
Maple input lines, respectively. Although these features are not used in this course, they may be useful
when preparing other reports in Maple

Desirable options that should be set in the Tools → Options. . . notebook are Input Display: Maple
notation — on the Display page — and Default format for new worksheets: worksheet — on the Interface
page. The other settings should be safe for our use.

The history of Maple Maple has been around for a long time. The symbolic computation
engine at the heart of the program was developed before the graphical interface that dominates present-day
computing, and this text-based interface continues to be available. A graphical worksheet for a variety
of platforms was introduced in one of the five releases of MapleV. This worksheet, identified by a mws
extension, can still be used, but Maple9 introduced a new worksheet format, identified by a mw extension,
based on XML and Java. These fundamental changes are important enough that only the new worksheet
format will be used in this course.

The interface to support this format also led to a vast improvement in access to help pages as you work
in Maple, and the help can be found just where you expect it on the menu bar of the application window.
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It is expected that you will consult the help pages as you work through the projects. In particular, many of
those pages contain examples of the use of Maple commands that will be useful in writing those commands
in the form that you want.

A new trend is an attempt to make Maple look more like standard mathematical notation. Mathemati-
cians have long used a two-dimensional approach to describing their subject. One of the earliest uses of the
graphical interface in Maple was to mimic this notation when showing the results of its work. Recently, there
have been steps to allow users to present their input in a similar notation. The “document mode” introduced
in Maple 10 further blurs the distinction between input and output with the goal of producing a neat report
that hides the effort to coax the Maple kernel to do the required computations. While you may find this
useful in other work, it is more useful when learning Maple to use the precise one-dimensional mark-up
language having its roots in the command line interface. Although mark-up languages often look clumsy,
they are unambiguous, so correct input leads to correct output. In the two-dimensional format, things that
look the same can be different. For example, exp(x) and eˆx are both shown as ex , but only the former
behaves correctly. This can even confuse Maple! In some versions, converting from a two-dimensional
format to traditional Maple input will give the latter expression, although the former is usually intended.

A product named GiNaC (see http://www.ginac.de/) has this to say about the shortcomings
of Computer Algebra Systems — in particular Maple: “First of all: Maple is a wonderful product. Yes,
it is. However, when you start writing large-scale applications you are doomed to run into trouble with it
unless you are extremely careful and know exactly what you are doing. One important problem with Maple
(and any other CAS) is the lack of a standardized up-to-date language. For instance, the concept of Object
Oriented design is not present. Quite generally, facilities for encapsulation are poorly developed. Maple’s
language is dynamically scoped and from time to time you find that Maple’s developers messed up with that
by not properly declaring variables to be local resulting in obscure (history-dependent) bugs. How are we
supposed to write scientific software with the language even the Maple developers have problems to handle?
Mathematica and Macsyma face the same problem, by the way.”

It continues: “Rather than pointing out a number of Maple’s linguistical and structural weaknesses let us
ponder about one simple fact. The purpose of symbolic computation is to simplify mathematical expressions
so that we can more easily understand their structure or code them more efficiently for numerical evaluation by
a computing machine. Most beginners simply use their Computer Algebra tool by typing in some expression
and then tell the system to simplify it, usually by a command with that name. This is fine, so far. However,
when several people embark on a large-scale project that relies considerably on symbolic computation,
it is unacceptable. This is because whenever somebody codes simplify(expression) somewhere, this is a
demonstration of his inability to understand what’s going on. Does he really want to simplify a rational
function by canceling a greatest common divisor from numerator and denominator? Or maybe he really
only wants to expand an expression and later collect for some variable? When the CAS manufacturer ships
the next release of his product, such calls to "simplify" are doomed to break. Sure, CAS do an amazing
job at simplifying results. But since nobody ever defined what simple really means the next release might
come up with different (though still hopefully correct) results. This frequently leads to subtle errors that are
very hard to debug. When you start a large-scale program involving Computer Algebra, it is a good idea to
memorize this: simplify is evil.”

We will give other examples of some expressions that need to be given in a special form, while the way
you have been writing mathematics will be considered to be an error. In Maple 10, there has been some
attempt to understand traditional input, but this is new and may not always work correctly.

Getting started The student labs should all have Maple10, but Maple 9 or 9.5 should work
equally well for all projects. On Unix systems, like eden, the graphical version is called xmaple, since it is
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customized to run under the X windows system. Since there are no longer X-terminals in the student labs,
most work will be done on PCs where all versions of Maple are usually installed on the “Course Related
Software” section of the Start Menu. It is also expected that the Microsoft Windows desktop on the lab
PCs will be taught to recognize Maple worksheets so that you can start Maple by selecting the file that you
want to open. The commands you use to do mathematics with Maple will be the same on all these machines,
although there may be differences in the way that files are opened, saved, and printed. The Tools menu
includes a Options item to change the appearance of Maple. Since other users of the lab machines may have
different preferences, you should learn how to use this to make sure that you will be working in Worksheet
mode (not the “Document Mode” introduced in Maple 10) with Maple input (not any form of 2-D input).

It is important that you be able to save worksheets to allow editing of your initial results. The best
place to save worksheets is in your eden directory. The standard way to do this is WebDrive. This
mounts a copy of your eden directory as a Windows drive (usually X:) and saves changes when you are
ready to logout. In addition, direct access to a special subdirectory of your eden directory is available by
Remote Drive Mapping using Samba, but this requires some advance planning and an extra password (see
http://www.eden.rutgers.edu/tools.php).

Starting with Maple 9, each worksheet opens in its own window. The appearance can be modified using
the Options menu, but the usual configuration has a Menu Bar, consisting of a row of menu buttons (File,
Edit etc.) at the top of the window, followed by a Tool Bar, most of which are shortcuts to menu commands,
and the a Context Bar, which consists of more buttons that are shortcuts to menu commands. If you have
enabled Tool Tips from the Interface page of the Options notebook accessible from the Tools menu, when
you place the mouse pointer on any of these buttons, a rough idea of what the button does will appear. There
is also a a small Status Bar at the bottom. The rest is devoted to the worksheet and a collection of palettes
that can be used to build common expressions (or hidden if you prefer to type your own formulas). You
can now give an instruction to Maple by placing the mouse pointer on the worksheet (just to the right of the
prompt >), typing a Maple command, and then a carriage return. Maple carries out the command and prints
a response. For example, if you type 1 + 1; , Maple will respond with 2. Note that each Maple command
ends with a semicolon (if you forget the semicolon, Maple will remind you) or a colon. Both the colon and
semicolon mark the end of a command. Usually the semicolon is used since this shows the output of the
command; the colon suppresses output in cases where it would clutter the worksheet.

If you select part of the worksheet, the right mouse button brings up a Context menu that can be useful
in editing the worksheet.

In order to guard against computer problems, you should save your worksheets often. Clicking on the
diskette icon on the Tool Bar of your Maple window is a convenient way to save the current worksheet.
You can also enable Auto Save from the General page of the Options notebook (see Help to learn how to
use this feature and to recover files that have been AutoSaved).

You can open several worksheets in the same Maple session. Prior to Maple9, the standard behavior
was for all worksheets in a session to share the same Maple kernel so that instructions in one worksheet
would be known to all worksheets in that session. This could be confusing, so older projects were designed
to be done in a single worksheet. Maple9 changed the standard to confine the effect of instructions to the
worksheet in which they are entered. This is known as the parallel kernel mode. The setting may be
checked (or changed) on the General page of the Options notebook. To take better advantage of the parallel
kernel mode, the idea of a Supplementary Worksheet was introduced into course projects in Fall 2004.
Now, you will work with two worksheets: one that starts from the Seed File and contains work that you
will submit for grading; and one Supplementary Worksheet for following suggestions and testing options
when constructing plots.

If you assign the result of a Maple computation to a name, that name will refer to that value for the rest
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of your Maple session unless you make another assignment to that name or use the restart; command
or the tool that looks like an oval with an arrow on it. Erasing the instruction from the worksheet will not
remove its effect. Also, only the order of executing instructions, not the position of the instructions in
the worksheet affects the values of named variables.

An alternative to naming results, introduced in Maple 10, is an equation label used to identify the last
result in an execution group. When a result is needed, its equation number may be inserted through the
menu bar of your Maple window, a context menu, or a keyboard shortcut (typically CTRL-L). The effect
is to bring up a dialog box in which you enter the current label. These labels are automatically updated if
commands are inserted or deleted.

These numbers refer to results in the worksheet, so they do not depend on the order in which commands
are executed. Furthermore, they are usually automatically updated as you edit the worksheet, so they should
always refer to the same value. If output is removed, the reference to an equation label will change to “??”,
but executing the worksheet restores the correct label and its result. On the other hand, references have been
seen to be destroyed by modifying the outline of the worksheet, so use of this feature is best left to later
stages of preparing the worksheet.

On the other hand, it is usually the case that, if you open a previously saved worksheet, none of the
results of that worksheet are known, even though they are visible in the worksheet. (This is changing:
Maple 10 introduces the ability to Auto-Execute parts of the worksheet to assure that important commands
are executed at the start of each session. This feature is so new that its use cannot be described here.) Your
new session will learn those results by executing the instructions, either one at a time by hitting the Enter
key on each line, are all at once using the Execute. . . Worksheet item in the Edit Menu or the !!! tool on
the toolbar. This step is also useful to check that results in your worksheet appear in the same order as the
instructions. This consistency is expected in the printed worksheets that you submit.

Getting Help from Maple Since you will not be given a Maple manual, you should learn
to use Maple by using the built in Help facility. There is a Help Menu at the right end of the menu bar.
Selecting any of the items in this menu will open the Help Browser Window (introduced in Maple 9 — a
less convenient set of help windows were used in earlier versions). New users are presented with this Help
Browser Window when Maple starts. The menu also identified Keyboard Shortcuts that will allow you
get the help you want quickly. You should learn these shortcuts.

Only one Help page at a time will be visible, but the browser includes a History panel as well as an
index and a search tool. The help pages give the exact syntax of Maple instructions and examples of their
use. It is expected that you will refer to this help to get the exact format of some instructions named in the
projects.

The Help Browser also contains pointers to Example Worksheets. One such, named Basic How To
introduces some frequently used Maple commands. The help menu also identifies Keyboard shortcuts to
quickly get the help you need.

Maple Worksheets The window that appears when you start Maple is called a Maple
worksheet. To complete each computer assignment in Mathematics 251 you are asked to turn in an edited
printout of your work. The printout should include only the numerical, symbolic, and graphical output
of Maple that is appropriate for the solution of the problems assigned, plus text material interpreting the
results obtained by Maple. Using the T tool will insert a new line into the worksheet in text mode, allowing
descriptive material to be added. (Undocumented Feature: Prior to Maple 9, this tool modified the current
line, but this change is not described in the documentation.) Text lines can also be used to label graphical
output, but better results can be obtained using the title option in the plot instruction. To modify the mode
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of the current line, use the Convert to submenu of the Format menu. The Insert menu also contains items
that modify the current line. Its Execution Group submenu may be used to add a line. This is the only
way to add a line before the cursor, but lines are more easily added after the cursor using the [> tool on the
toolbar. The input lines of your worksheet should begin with a > prompt. If you don’t see a prompt, you
may be in a document block where rules different from those described here apply. Maple includes various
editing capabilities that should enable you to produce neat and coherent output, which we now describe.

To remove an unwanted portion of your Maple worksheet (e.g., a region containing commands that
you typed incorrectly or that were not directly relevant to the solution of the exercises), select the region
to be deleted by clicking the left mouse button at the beginning, then dragging the mouse across to the end
of the portion of the worksheet you wish to delete. The region should now be highlighted. The Delete
key will purge what you have selected. A safer approach is to choose Cut from the Edit menu or toolbar.
This allows you to copy the removed region to a new location by selecting Paste from the Edit menu or
toolbar. There is also a Copy tool, and an item in the Edit menu, that makes a region available for pasting
without removing it from the worksheet. These operations are borrowed from your computer’s Window
Manager, so it should be possible to copy parts of your Maple worksheet to other applications. You can also
delete whole lines with the Ctrl-Delete key combination. You should experiment with the different aspects
of the user interface (mouse, keyboard, menu or toolbar items) to find the method that you find easiest for
customizing the appearance of your worksheet. When text is highlighted, the right mouse button brings up
a Context Menu that contains the commands from the Edit Menu.

Sometimes it is useful to be able to place a comment after a Maple command, rather than insert text
elsewhere in the worksheet. To do this, enter the number symbol #. Everything typed on a line following
this symbol will be considered by Maple to be a comment, and therefore not executed.

To make your worksheet less cluttered, it is a good idea to have Maple suppress the output of various
commands, e.g., the command with(plots) or a command given to assign a name to a plot. To do this,
end the command with a colon (:), instead of a semicolon (;).

Obtaining the Labs in Worksheet Form In some of the labs, part of the lab will ask
you to execute a string of Maple commands to learn what they do. To avoid retyping these commands, you
can first obtain a modified copy of the lab in worksheet form (a “seed file”) from the course web page. These
seed files have now become an essential part of these lab projects, since some sample Maple instructions
appear only in the seed file.

A change made during the Fall 2004 semester is the use of a Supplementary Worksheet for work
related to a project that should not appear in the final report. Because this will contain important clues, this
worksheet should also be obtained before starting your work. The parallel kernel mode keeps the work in
these two worksheets separate, but you can copy instructions from one worksheet to the other.

Opening an Existing Worksheet File managers should be configured to start Maple
when you activate the icon of a worksheet file. To open an existing worksheet while Maple is running, you
can choose Open from the File Menu or the toolbar. A dialog box will be shown. Navigate in that box to
the correct directory and select the name of the file you wish to open and then click on the Open button at
the bottom of the box.

Arithmetic The operations addition, subtraction, multiplication, and division are indicated
by +, -, *, / respectively. Fractions are represented exactly, and Maple automatically reduces them to
lowest terms. Thus, if you type 1/3+1/6; , Maple will answer 1/2. Exponentiation is also available with
the operator ˆ, but it should be used sparingly. Many expressions that we write using exponents are better
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described using the exponential function described in a later section. If you select ea from a palette when
input is set the Maple Input, you will get the correct expression exp(a).

When operating on integers or fractions, Maple will do exact arithmetic, rather than using decimal
approximations. To get a decimal approximation, use the Maple command evalf. The Maple command
evalf(4/7); produces a 10 digit approximation to 4/7—as will typing4.0/7.0; . Additional accuracy
can be obtained by including a modifier: typingevalf[20](4/7);will produce a 20 digit approximation.
(Note: this form of the evalf function is now standard, replacing an older form evalf(4/7,20);. The
older form is still accepted, but no longer described in the Help file.) You can also change precision for your
whole Maple session by setting a new value to the reserved variable Digits. Selecting the output of an
exact computation will allow some conversions to be made by using the right mouse button to get a context
menu.

Algebra All grouping of expressions is done with the left and right parentheses — “(” and “)”
— since other types of brackets have special meaning. Although the usual rules of precedence apply, you
can always use parentheses to clarify your intent. Variables are not limited to single letter names, as in
Elementary Algebra (and most Calculus texts). You can use (almost) any string of letters and numbers that
starts with a letter to name a variable. As a result, the product xy must be written x*y, not xy or x y; if
you type xy, Maple will assume you are referring to a variable called “xy”. Thus, to enter the expression
(2x + y2)/(x2

+ y) + 1 into Maple, you type:

(2*x +yˆ2)/(xˆ2 + 2*y) + 1;

Recent versions of Maple allow you to use a palette to help build expressions. The choice of palettes can
be configured from the View menu. This will give the correct form of the expression for the selected input
mode. It can help translate the standard mathematical notation in project descriptions into Maple input in
your worksheet.

To help you do algebraic manipulations, Maple has the commandsexpand, factor, andsimplify,
which you can learn about by using the Help facility. It is often necessary to expand an expression before
Maple will know what it means to simplify it. In particular, Maple considers

(2*x +y)*(x + 2*y);

to be simple. Likewise, after you expand this expression, Maple will consider the expanded form to be
simple, but the factor command can be used to return the factored form.

Algebraic numbers like
√

2 are considered to be exact quantities. If you enter

a:=(sqrt(2)+1)ˆ10;

Maple will appear to simply echo a prettyprint version of that statement.
To get an answer in the form 3363 + 2378 ∗

√
2, follow this line with expand(a); .

You can also solve algebraic equations using the commands solve (for exact answers) or fsolve
(for numerical answers to the accuracy specified by Digits).

The standard functions Note that the exponential function is built into Maple and is
referred to as exp. The number e, if you ever need it, is exp(1). If you have the fragment eˆx in a
worksheet, it will look right, but will usually give incorrect results when you try to use it. Similarly, the
number π has the special name Pi — not pi that looks the same in output lines, but will be treated as an
ordinary variable (this may change in future releases, but it is still correct in Maple 10). If you want to, you
can say pi:=3; but this won’t affect the value of π or anything that depends on it. However, Maple will
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fuss at you if you try to change the value of Pi. Except for Pi, that has been part of Maple for a long time,
other names that are Greek letters — upper or lower case — are shown as that letter in output. This can be
confusing in cases like Mu where the Greek letter looks like a related Latin letter. Maple also recognizes
names like log, ln, sin, cos, tan as standard functions. Those names are also protected against use
as names of variables. Normally, log is treated as a synonym for ln — to get the common logarithm
of 2 that your calculator uses, you should write log10(2.); or log[10](2.);. The instruction,
FunctionAdvisor(known functions); will give you a list of names of the functions that are
available. Many of these have unfamiliar names since they are defined in advanced mathematics, but you
should recognize all the elementary functions that you learned how to differentiate in CalculusI.

User-defined Functions and Expressions In Maple, xˆ2 - 2*x +3 is an
expression. You can use a name to refer to this expression for future use by typing g:= xˆ2 - 2*x
+3; . Note that a colon is required before the equal sign in an assignment statement. Expressions can
contain several variables, as in h:= y*t - sin(y). To evaluate an expression at a particular value, use
the Maple command eval. For example, eval(g,x=2); will produce the value 3. In many cases, the
Maple command subs has a similar effect, although the order of the arguments is different. For example,
subs(x=2,g); will also produce the value 3. If you decide to name something after you have evaluated
it, the context menu for the result of the computation includes an option to assign to a name.

Maple also has a construct called a function, defined by statements like f:=x -> xˆ2 - 2*x
+3; . This allows you to recover the expression x2

− 2 ∗ x + 3 as f(x); , and to perform evaluation using
the familiar notation f(2); . It is also possible to substitute expressions for x — even expressions that
contain x — and get the result that you expect. For example, f(x+1); returns (x + 1)2

− 2 ∗ x + 1, which
you could expand or simplify to get x2

+ 2.
We won’t often use functions, except for pre-defined functions like exp(x) or cos(x), since it is

easier to work with expressions, but you might see them in examples on Help screens. Some seed files may
also define functions to extend the Maple language on that worksheet. While we don’t expect you to write
functions in the Maple programming language, you should have no difficulty reading these definitions.

Plots The basic graphing command in Maple is plot. This command has many forms—for
example, several functions can be plotted at once—so you should look carefully at the examples given at
the end of its Help page to get some idea of its flexibility. There are many other plotting commands in
Maple; in this course we will use primarily plot3d and implicitplot. To use all but the most basic
plotting tools you must first issue the command with(plots); to load a library of procedures written
in the Maple language. For example, this is necessary in order to use the command implicitplot. You
can also modify the style of the plot using the Control bar or context menu (obtained by clicking the right
mouse button when the cursor is near the plot). These changes will lead to a plot with features not shown
in the instruction that drew the original plot. One of the main uses of the supplementary worksheet will
be to experiment with plots and determine the options that give the plot that you want. When you have
determined all options, write the complete plot command at a > prompt in your main worksheet. Then, the
plot will be drawn the same way every time that worksheet is executed.

When viewing three dimensional plots, it is useful to view the plot from different viewpoints. First,
place a box around the plot by moving the mouse pointer in the region occupied by the plot and clicking
the left mouse button. Now, place the mouse pointer inside the box and while holding down the left mouse
button, move the mouse pointer to different positions. You should also explore the effects of using the Axes
and other commands.

A PlotBuilder was introduce in Maple 9. It has been modified in subsequent releases, so now it is
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mostly useful for producing one plot or a single instruction for drawing it.

Vectors As of Maple6, Maple now has two different packages for linear algebra. These packages
allow powerful operations to be introduced simple by calling them by name. The original linalg package
imposed a complicated structure on everything it touched. As a result, simple things became more difficult.
The newer LinearAlgebra package is easier to use and is the basis of a VectorCalculus package
that allows you to communicate to Maple using the terminology introduced in this course.

Calculus In addition to performing basic calculations and evaluating expressions containing stan-
dard functions, Maple can also differentiate and integrate. The diff command differentiates expressions.
For example, diff(x*sin(x), x); differentiates x sin(x) with respect to x . If you have named an
expression, it is a useful convention to introduce a modification of that name as a name for the deriva-
tive (or partial derivatives). That is, if you have y:=x*sin(x);, you can write y1:=diff(y,x);.
A second derivative can then be found, and named, by writing y2:=diff(y1,x); to differentiate the
first derivative using the name that you introduced. If you need a second derivative without seeing the
first derivative, either diff(x*sin(x), x, x); or diff(x*sin(x),x$2); may be used. If you
have typed g:=xˆ2*y; , then diff(g,x); gives the first partial derivative of x2 y with respect to x and
diff(g,x,y); is the mixed second partial derivative. It is also possible to differentiate functions, but
this uses a totally different set of conventions.

Note that Maple assumes that everything not involving the variable with which it is differentiating is
constant. This means that no special notation is required to distinguish partial derivatives of expressions
from ordinary derivatives. Note that, although we claim to be differentiating functions in Calculus, the
techniques are based on examining how variables appear in expressions, so the way that Maple works with
expressions is more familiar.

The command for both definite and indefinite integration is int. If Maple cannot evaluate a definite
integral exactly, numerical integration may be used. Definite integrals are evaluated using a single instruction
written like int( sin(x), x=0..Pi ); to get∫ π

0
sin x dx .

It is not necessary to apply either thesubs oreval instruction to the result of indefinite integration, although
that approach gives the same answer. The role of dx in the mathematical notation for integrals is played by
including the name of the variable x in the second argument of the int instruction.

The VectorCalculus package includes commands to work with the extend forms of differentiation
and integration introduced later in this course.

Maple9 also includes a package named Student[Calculus1] that you can use to review basic
calculus. There are interactive worksheets that allow you to practice the techniques of basic calculus and
to step through the solution of problems. The help pages will guide you in the use of this package.

Printing your Maple Worksheet. In most cases, the projects in this course are to be
submitted as printed worksheets. Usually, two weeks are allowed from the time the project is assigned
until the printed worksheet is due. This allows you to explore different approaches to the project and to edit
your results.

To print a Maple worksheet, choose Print from the File menu or click on the print button in the Tool
Bar (its position varies, but it is with the other file tools at the left and its icon looks like a printer). A
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panel will appear with the options “Output to File” and “Print Command” at the top. Clicking on “Print
Command” will direct your output to the printer if the command has been correctly entered, while clicking
on “Output to File” places your output in a file, whose name and location will be chosen in another dialog
box (the default is out.ps). If you wish to change the file name or the print command, click in the box and
type your changes. Since the file will be a postscript file, the file name should have a ps extension. When
you have finished making your choices, click on the “Print” button.

You should also use the following tools to improve the appearance of your printed worksheet.
(1) Print Preview to see how your worksheet will appear before you commit it to paper.
(2) The page break item in the Insert Menu to force extra page breaks as needed to improve readability.

The location of the break is shown in the worksheet on your screen.

Saving your Maple Worksheet. If your work is interrupted, you can save your work so
that you can resume later where you left off. There is a tool on the toolbar that saves a worksheet under its
current name if it has one, or prompts you for a place to save a newly created worksheet. In addition, the
File menu contains the usual Save and Save As options. The mw extension will be added to the name that
you give.

It is also possible to save the file in the older mws format, but this may lose features introduced after
Maple8. Don’t do this unless absolutely necessary, and inform your instructor if you will not be able to
complete the worksheet in Maple9 (or newer).

Ending your Maple Session To end your Maple session, choose Exit from the File
menu. When you close a worksheet, or exit the program, Maple will prompt you to save worksheets that
have changed since the last save. This may only save the worksheet of the PC in the lab. That file will then
need to be copied to your directory on eden to have it available for later editing (although both WebDrive
and Samba should do this automatically).

Useful Commands and Techniques. If Maple gets hung up in a calculation or is
taking too long, click the mouse on the stop button in the Tool Bar menu. This usually means that the
command that Maple was working on was incorrect. An alternative approach to the calculation may give
the desired result. Computational efficiency is usually not an issue on modern computers, so you shouldn’t
try to find the best way to compute something. However, you should check that reasonable results are
obtained fairly quickly.

Any Maple command previously entered in your worksheet can be re-executed without retyping it in a
new location. Simply move to the position of the command you wish to execute with the mouse and hit the
Enter (or Return) key. However, this works only for the current session. If you need the instruction at a
different point in the worksheet, it should be moved or copied there.

It is often useful to be able to refer later to the result of a computation—the output of some command—in
a simple way. To make this possible, simply assign the output of the command to a variable. For example, if
you enter a:= evalf(2*Pi); then you can later square the result of evalf(2*Pi); by typing a*a; .
It you find that you need a recent result that was not named, the special names %, %%, etc. may be used to
refer to the previous result, the one before that, etc. (the instructions are not clear about how much of the
history can be retrieved in this way). Maple 10 introduced line numbers for output. These can be used via
a context menu to insert previous results in new commands. A better solution might be to add a name for
the result on the line that computed the expression and re-execute that line. This effect can also be obtained
with a context menu.
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You can assign a name to a plot just as described above for assigning a name to an expression, but an
instruction creating a named plot should always end with a colon instead of a semicolon — you usually
don’t want to see that output. A single named plot can be viewed by entering the name of the plot followed
by a semicolon on an input line, and several previously named plots can then be displayed on the same graph
by using the command display. This is part of the plots library. Looking in the documentation for that
library may be the easiest way to find the help page for this function.

Only the most recent assignment to a name is remembered. You can unassign a by typing a:=’a’; .
To clear all the assigned variables in a Maple session, you can type restart; as indicated earlier. If you
are unsure of what value has been assigned to the name a, you can type a; at the current prompt. Such
working notes should be edited out of the main worksheet before you submit it.

Getting Help From Other Students The course includes some laboratory projects
that form a small portion of your grade. Just as with other homework assignments, it is permissible and
helpful to discuss these Maple labs with other students. However, the Maple lab reports that you turn in
are being graded and will be part of your final course grade. As with all such work, the printed form of
the worksheet is expected to be the work of the student who submits it. In particular, the projects include
questions that involve your interpretation of results of Maple’s computation. The grader will concentrate
on the text comments that contain your answers to these questions. These comments are expected to reflect
your individual understanding of the topic and the grader will notice when several students submit nearly
identical statements..

End of Maple instructions document
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